辅助开发工具(st)

当前版本 下载次数 最近提交 Github 仓库

安装

本软件使用 Rust 语言编写,如果您本地有 Rust 环境,可以直接使用:

cargo install st-cli

来进行安装。

警告

可执行程序的文件名为: st 不是 st-cli

待处理

允许其他安装方式(例如: apt 或者 yum)。

使用

安装完毕之后,可以命令行输入: st --help 获取帮助信息。

st 0.6.3

USAGE:
    st <SUBCOMMAND>

FLAGS:
    -h, --help       
            Prints help information

    -V, --version    
            Prints version information


SUBCOMMANDS:
    build       编译
    bump        提升版本
    clean       清理开发环境
    django      django 子命令
    format      格式化代码
    help        Prints this message or the help of the given subcommand(s)
    install     本地安装
    lint        代码检测
    lock        锁定依赖
    outdated    检测依赖是否有新版
    publish     发布
    run         运行
    sync        同步依赖
    test        测试
    update      升级依赖版本

注解

以上内容是当前版本输出的帮助信息

子命令说明

build

Rust

cargo build

Python

poetry build

警告

不支持其他语言

bump

当前已经废弃,不建议使用。

clean

清理当前项目

Rust

cargo clean

NPM

npm cache clean

Poetry

poetry run pip cache prune

django

dump-data

导出数据

load-data

导入数据

collect-static

收集需要发布的静态文件

警告

不包含模版文件。

format

Rust

cargo fmt

Python

black (依赖 black 和 Poetry)